СБОРНИК МЕТОДИЧЕСКИХ УКАЗАНИЙ ДЛЯ СТУДЕНТОВ ПО ВЫПОЛНЕНИЮ Лабораторной работы №12-13 «Изучение виртуальных локальных сетей VLAN» МЕЖДИСЦИПЛИНАРНЫЙ КУРС МДК «ИНФОКОММУНИКАЦИОННЫЕ СИСТЕМЫ И СЕТИ» специальность 09.02.03 «Программирование в компьютерных системах» ДЛЯ СТУДЕНТОВ ОЧНОЙ ФОРМЫ ОБУЧЕНИЯ


Министерство образования Республики Башкортостан
УФИМСКИЙ КОЛЛЕДЖ РАДИОЭЛЕКТРОНИКИ, ТЕЛЕКОММУНИКАЦИЙ И БЕЗОПАСНОСТИ
СБОРНИК МЕТОДИЧЕСКИХ УКАЗАНИЙ
ДЛЯ СТУДЕНТОВ ПО ВЫПОЛНЕНИЮ
Лабораторной работы №12-13 «Изучение виртуальных локальных сетей VLAN»
МЕЖДИСЦИПЛИНАРНЫЙ КУРС
МДК «ИНФОКОММУНИКАЦИОННЫЕ СИСТЕМЫ И СЕТИ»
специальность 09.02.03 «Программирование в компьютерных системах»
ДЛЯ СТУДЕНТОВ ОЧНОЙ ФОРМЫ ОБУЧЕНИЯ
РАЗРАБОТЧИКИ:
___________ И.В. Нуйкин
Уфа 2016
ПРЕДИСЛОВИЕ
Методические указания для студентов по выполнению лабораторных работ являются частью основной профессиональной образовательной программы Государственного бюджетного образовательного учреждения среднего профессионального образования «Уфимский государственный колледж радиоэлектроники, телекоммуникаций и безопасности» по специальности СПО 09.02.03 «Программирование в компьютерных системах» в соответствии с требованиями ФГОС СПО третьего поколения.
Методические указания для студентов по выполнению лабораторных работ адресованы студентам очной и заочной с элементами дистанционных технологий форм обучения.
Методические указания созданы в помощь для работы на занятиях, подготовки к лабораторным работам, правильного составления отчетов.
Приступая к выполнению лабораторной работы, необходимо внимательно прочитать цель работы, ознакомиться с требованиями к уровню подготовки в соответствии с федеральными государственными стандартами третьего поколения (ФГОС-3), краткими теоретическими сведениями, выполнить задания работы, ответить на контрольные вопросы для закрепления теоретического материала и сделать выводы.
Отчет о лабораторной работе необходимо выполнить и сдать в срок, установленный преподавателем.
Наличие положительной оценки по лабораторным работам необходимо для допуска к экзамену, поэтому в случае отсутствия студента на уроке по любой причине или получения неудовлетворительной оценки за лабораторную работу необходимо найти время для ее выполнения или пересдачи.
Правила выполнения практических работ
1. Студент должен прийти на лабораторное занятие подготовленным к выполнению практической работы.
2. После проведения лабораторной работы студент должен представить отчет о проделанной работе.
3. Отчет о проделанной работе следует выполнять в журнале практических работ на листах формата А4 с одной стороны листа.
Оценку по лабораторной работе студент получает, если:
- студентом работа выполнена в полном объеме;
- студент может пояснить выполнение любого этапа работы;
- отчет выполнен в соответствии с требованиями к выполнению работы;
- студент отвечает на контрольные вопросы на удовлетворительную оценку и выше.
Зачет по выполнению лабораторных работ студент получает при условии выполнения всех предусмотренных программой работ после сдачи журнала с отчетами по работам и оценкам.
Внимание! Если в процессе подготовки к лабораторным работам или при решении задач возникают вопросы, разрешить которые самостоятельно не удается, необходимо обратиться к преподавателю для получения разъяснений или указаний в дни проведения дополнительных занятий.
Обеспеченность занятия (средства обучения):
Учебно-методическая литература:
Основные источники:
-Е.О. Новожилов. О.П. Новожилов, Компьютерные сети: 2009учебное пособие для студ. учреждений сред. проф. Образования.-М.:Издательский центр «Академия», 2011.-304с
- Олифер В.Г., Олифер Н.А. Основы компьютерных сетей.- СПб.: Питер, 2009-352с.
- Таненбаум Компьютерные сети.4-е изд.-Спб.:питер,2009.-992с.
-Олифер В.Г., Олифер Н.А., Компьютерные сети. Принципы, технологии, протоколы: учебник для вузов.3-изд.-СПб.: питер, 2008.-958 с.
-Максимов Н.В.. Партыка Т.Л., Попов И.И., Технические средства информатизации: учебник.-2-е изд.,-М.: ФОРОУМИНФРА-М,2008.-592 с.
- Виснадул Б.Д.. Лупин С.А. Основы компьютерных сетей: учебное пособие/ Под ред. Л.Г. Гагариной М.: ИД «Форум»: ИНФРА-М, 2007.-272 с.
-Основы компьютерных сетей: учебное пособие/ Б.Д. Виснадул.-М.: ИД «Форум»: ИНФРА-М, 2009.-272 с
Дополнительные источники:
-Компьютерные сети: Учебное пособие по администрированию локальных и объединенных сетей/ А.В. Велихов, К.С. Cтрочников, Б.К. Леонтьев/-3-е изд., доп. и испр.- М.:ЗАО «новый издательский дом», 2005.-304.
-Башлы П.Н. Современные сетевые технологии.: Учебное пособие.- М.:Горячая линия-Телеком, 2006.-334
Справочная литература:
справочники по компьютерным сетям, стандарты
Технические средства обучения:
- персональные компьютеры ( объединенные в учебную локально- вычислительную сеть с выходом в сеть Интернет) по количеству обучающихся, мультимедиапроектор, ноутбук преподавателя;
- принтер;
- интерактивная доска;
- учебно-лабораторный комплекс «корпоративные сети» (аппаратный брандмауэр. Управляемые коммутаторы 2-го и 3-го уровня, беспроводной маршрутизатор, неуправляемый коммутатор, набор коммутационных кабелей витой пары);Программное обеспечение: MS Office, OC Windows, OC UnixОтчет по выполнению практических работ
Порядок выполнения отчета по лабораторной работе
Ознакомиться с теоретическим материалом по практической работе.
Записать краткий конспект теоретической части.
Выполнить предложенное задание согласно варианту по списку группы.
Продемонстрировать результаты выполнения предложенных заданий преподавателю.
Записать код программы в отчет.
Ответить на контрольные вопросы.
Записать выводы о проделанной работе.
Лабораторная работа №12-13
Изучение виртуальных локальных сетей VLAN
Образовательные результаты, заявленные во ФГОС третьего поколения:
Студент должен
уметь:
- применять стандартные методы для защиты объектов.
знать:
- основные приемы работы в компьютерных сетях;
- технологии передачи и обмена данными в сетях;
- информационные ресурсы компьютерных сетей.
Краткие теоретические и учебно-методические материалы по теме практической работы:
Локальные сети в настоящее время принято строить на основании технологи коммутируемого Ethernet. Стремятся минимизировать число используемых концентраторов (хабов-hab) и использовать преимущественно коммутаторы (свичи - switch). В коммутаторе между приёмником и передатчиком на время соединения образуется виртуальный канал (virtual circuit) точка-точка. Такая сеть может быть рассмотрена как совокупность независимых пар приёмник-передатчик, каждая из которых использует всю полосу пропускания. Коммутатор позволяет осуществлять параллельнуюпередачу информации. Коммутация уменьшает вероятность переполнения в сетях Ethernet.
Если коммутатору необходимо передать пакет на какой-то выходной порт, и этот порт занят, то пакет помещается в буферную память. Это позволяет согласовать скорости передатчиков и приёмников пакетов.
Для отправки фрейма через коммутатор используются два метода:
Отправка с промежуточным хранением (store-and-forward). Пакет должен быть принят полностью до того как будет начата его отправка.
Сквозной метод (cut-through). Коммутатор принимает начало пакета, считывает в нём адрес пункта назначения и начинает отправлять пакет ещё до его полного получения.
Ethernet-коммутатор узнаёт МАС адреса устройств в сети путём чтения адресов источников в принимаемых пакетах. Коммутатор запоминает в своих внутренних таблицах информацию на какие порты и с каких МАС адресов приходят пакеты. При подключении к одному порту нескольких устройств через концентратор (hub) в таблице одному порту будет соответствовать несколько MAC- адресов. Таблицы хранятся в памяти, адресуемой по смыслу (content-addressable memory, CAM): если адрес отправителя отсутствует в таблице, то он туда заносится. Наряду с парами адрес-порт, в таблице хранится и метка времени. Метка времени в строке таблицы изменяется либо при приходе на коммутатор пакета с таким же адресом, либо при обращении коммутатора по этому адресу. Если строка таблицы не использовалась определённый период времени, то она удаляется.
Это позволяет коммутатору поддерживать правильный список адресов устройств для передачи пакетов.
Используя CAM таблицу адресов и содержащийся в пришедшем пакете адрес получателя, коммутатор организует виртуальное соединение порта отправителя с портом получателя и передает пакет через это соединение. Виртуальное соединение между портами коммутатора сохраняется в течение передачи одного пакета, т.е. для каждого пакета виртуальное соединение организуется заново на основе содержащегося в этом пакете адреса получателя.
Поскольку пакет передается только в тот порт, к которому подключен адресат, остальные устройства подключенные к коммутатору, не получат этот пакет.
В коммутаторах Ethernet передача данных между любыми парами портов происходит независимо и, следовательно, для каждого виртуального соединения выделяется вся полоса канала.
При передаче широковещательного пакета, в коммутаторе образуется «веер» каналов по принципу один ко многим. Примерами источников широковещательного трафика являются ARP и маршрутизирующие протоколы.
Коммутаторы можно соединять друг с другом. При этом группа попарно прямо либо косвенно связанных коммутаторов образует один логический коммутатор с теоретически произвольным числом портов. То есть коммутаторы позволяют создавать теоретически сколь угодно большую локальную сеть. Правильное соединение коммутаторов, то есть выбор топологии сети составляет одну из важнейших задач проектирования локальных сетей.
Рекомендуется осуществлять соединение коммутаторов по слоям (рисунок 1): серверный слой, слой распределения (distribution) и слой доступа (access). Рядовые компьютеры подключаются к слою доступа, а сервера к серверному слою.

Рисунок 1.
Главным препятствием для создания больших локальных сетей с помощью одних только коммутаторов является нелинейный рост объёма широковещательного трафика с ростом числа устройств в сети. При числе устройств в сети более, чем 2000 (по другим оценкам 500, по третьим 4000 – всё зависит от топологии сети и класса решаемых задач) объём широковещательного трафика резко возрастает. Добавление новых устройств
резко снижает производительность сети. Например. Если в сети из нескольких тысяч устройств один из компьютеров A впервые осуществляет IP соединение с другим компьютером
B в этой сети, то он должен предварительно послать ко всем устройствам
сети широковещательный ARP запрос для определения MAC адреса компьютера B.
Локальная сеть, созданная с помощью одних только коммутаторов представляет один домен широковещания. Уменьшить домен широковещания можно, физически разделив локальную сеть на независимые подсети (независимые группы попарно связанных коммутаторов) и соединить их в единое целое с использованием маршрутизаторов. Такую задачу можно решить только на этапе построения сети, но не в момент её эксплуатации. Здесь на помощь приходят виртуальные локальные сети
VLAN (virtual local area network).Виртуальная локальная сеть VLAN представляет собой совокупность портов одного или более коммутаторов (Рисунок 2).

Рисунок 2.
VLAN позволяют логически разбить исходную локальную сеть на несколько независимых локальных сетей без физического обрыва сетевых соединений. Для этого администратор сети должен на каждом коммутаторе назначить, какие его порты относятся к каким VLAN. По умолчанию все порты коммутатора относятся к одной VLAN с номером 1. Максимальное число VLAN в коммутаторе равно общему числу его портов. Правильная разбивка локальной сети на VLAN составляет одну из важнейших задач
проектирования.
VLAN ведут себя так же, как и физически разделённые локальные сети. То есть после разбивки сети на VLAN мы получим несколько локальных сетей, которые далее необходимо объединить в единое целое с помощьюмаршрутизации на третьем сетевом уровне.
Концепция VLAN, помимо решения проблемы с широковещательным трафиком даёт также ряд дополнительных преимуществ: формирование локальных сетей не по месту расположения ближайшего коммутатора, а по принадлежности компьютеров к решению той или иной производственной задачи; создание сети по типу потребляемого вычислительного ресурса и требуемой серверной услуги (файл-сервер, сервер баз данных). VLAN позволяют вести различную политику безопасности для разных виртуальных сетей; переводить компьютер из одной сети в другую без осуществления
физического перемещения или переподключения.
Для обмена информацией о VLAN коммутаторы используют магистральный (транковый) протокол. Для осуществления обмена информацией о VLAN между коммутаторами вы должны создать магистральные порты. Магистральный порт это порт, используемый для передачи информации о VLAN в другие сетевые устройства,
присоединенные к этому порту. Обычные порты не рекламируют информацию о VLAN, но любой порт может быть настроен для приема/передачи информации о VLAN. Вы должны активизировать магистральный протокол на нужных портах, так как он выключен по умолчанию.
Порт коммутатора работает либо в режиме доступа либо в магистральном режиме. Соответственно связь, подсоединённая к порту является либо связью доступа либо магистральной связью. В режиме доступа порт принадлежит только одной VLAN. Порт доступа присоединяется к оконечному устройству: ПК, рабочей станции, серверу,
хабу. Фреймы, проходящие через порт доступа, являются обычными Ethernetфреймами.
Магистральные связи способны поддерживать несколько VLAN. VLAN на различных коммутаторах связываются через магистральный протокол. Магистральные порты не принадлежат определённой VLAN и используются для подсоединения к другим коммутаторам, маршрутизаторам или серверам, имеющим сетевые адаптеры с возможностью для подключения ко многим VLAN.Магистрали могут расширить VLAN по всей сети. Для магистральных целей назначают высокоскоростные порты коммутаторов: Gigabit Ethernet и 10Gigabit .
Для мультиплексирования трафика VLAN существуют специальные протоколы, позволяющие приёмным портам определить, какому VLAN принадлежит пакет. Для связи между устройствами Cisco используется протокол Inter-Switch Link (ISL). При наличии в сети оборудования нескольких производителей применяется протокол IEEE 802.1Q
Без магистральных связей для поддержки VLAN должно быть организовано по одной связи доступа для каждой VLAN. Такой подход дорог и неэффективен, поэтому магистральные связи абсолютно необходимы при проектировании локальных сетей.

Рисунок 3.
На рисунке 3 порты А и В на коммутаторе Y определены как связи доступа на одной и той же VLAN 200. По определению они могут принадлежать только одной VLAN и не могут получать ethernet фреймы, содержащие идентификатор VLAN. Например, когда Y получает трафик от порта А к порту В, то он не добавляет ISL заголовокок в ethernet фреймы.
Порт С на коммутаторе Z также является портом доступа и также принадлежит к VLAN 200. Если порт А пересылает фрейм в порт С, то происходит следующее:
1. Коммутатор Y получает фрейм и, сопоставляя номер порта назначения с номером VLAN, определяет его как трафик, направленный к VLAN 200 на другом коммутаторе,
2. Коммутатор Y добавляет к фрейму ISL заголовок с номером VLAN и пересылает фрейм через промежуточный коммутатор на магистральную связь.
3. Этот процесс повторяется на каждом коммутаторе по пути фрейма к конечному порту С.
4. Коммутатор Z получает фрейм, удаляет ISL заголовок и направляет фрейм на порт С.
Если порт находится в магистральном режиме, то он может быть настроен или для транспорта всех VLAN или ограниченного множества VLAN. Магистральные связи используются для связи коммутаторов с другими коммутаторами, маршрутизаторами или с серверами, имеющими поддержку VLAN.
Согласно базовой терминологии магистраль это связь точка-точка, поддерживающая несколько VLAN. Целью магистрали является сохранение номеров портов при создании связи между двумя устройствами, образующими VLAN.

Рисунок 4.
Верхняя фигура на рисунке 4 показывает способ создания VLAN путём использования двух физических связей между коммутаторами (по одной на каждую VLAN). Это решение плохо масштабируется: при добавлении третьего VLAN надо пожертвовать ещё двумя портами. Это решение неэффективно и в смысле разделения нагрузки: малый трафик на некоторых связях может не стоить того, что эта связь является пучком виртуальных
связей через одну физическую связь. На нижней фигуре одна физическая связь способна нести трафик для любой VLAN. Для достижения этого коммутатор Sa так оформляет фреймы, что Sb знает, на какую VLAN они направляется. Для такого оформления пакетов используются либо стандарт IEEE 802.1Q либо Cisco протокол ISL (Inter-Switch Link).
Для больших сетей ручная конфигурация VLAN становится весьма трудоёмкой задачей. Cisco VLAN Trunk Protocol (VTP) служит для автоматического обмена информацией о VLAN через магистральные порты.
Преимуществом использования VTP является то, что вы можете контролировать добавление, удаление или изменение сетей VLAN из коммутаторов на котором созданы VTP сервера. После настройки ваших коммутаторов как VTP серверов, остальные коммутаторы вашей сети могут быть настроены как клиенты, которые только получают VLAN информацию.
Недостатком является ненужный трафик, создаваемый на магистральный портах для устройств, которым возможно не нужна эта информация. Если ваша сеть будет содержать много коммутаторов, содержащих много виртуальных сетей, расположенных в разных коммутаторах, возможно, имеет смысл использовать VTP. Если ваша сеть останется
достаточно статической, и VLAN не будут добавляться или изменяться по отношению к начальной конфигурации, то лучше использовать статическое определение виртуальных сетей.В топологии локальных сетей возможны циклы (петли). Например, уже
три коммутатора соединённых друг с другом по кругу образуют цикл в топологии. Петли приводят к неоднозначности при определении пути от источника пакетов к приёмнику. Для решения этой серьёзной проблемы был разработан протокол связующего дерева STP (spanning tree protocol). Для графа топологии каждой VLAN, которая определена в сети, строится минимальное покрывающее дерево (граф без циклов) с вершиной внекотором коммутаторе. Для физической реализации таких деревьев STP переводит избыточные порты в состояние блокировки. Расчёт деревьев производится параллельно на всех коммутаторах. Далее пакеты во VLAN идут только по путям, определённым в построенных покрывающих деревьях.
При изменении топологии, активации/остановке портов происходит пересчёт
покрывающих деревьев.
Для создания топологии связующего дерева существуют специальные фреймы, называемые модулями данных мостового протокола (bridge protocol data units, BPDU). Эти фреймы отправляются и принимаются всеми коммутаторами в сети через равные промежутки времени.
Задания для практического занятия:
Конфигурирование статических VLAN
1. Статические VLAN это совокупность портов на коммутаторе, которые вручную назначаются командой IOS при конфигурировании интерфейса.
Для создания пустой VLAN c номером №VLAN на коммутаторах Cisco серии 2950 используются команды
Switch#vlan database
Switch(vlan)#vlan №VLAN
Switch(vlan)# exit
Например, команды
Switch#vlan database
Switch(vlan)#vlan 33
Switch(vlan)# exit
создадут пустую VLAN с номером 33 и система даст VLAN имя VLAN0033.
Заметим, что команды выполняются не в режиме конфигурации.
Команда switchport mode используется для установки интерфейса в динамический режим, режимы доступа или режим магистрали (trunk).
Switch(config-if)#switchport mode [access | dynamic | trunk]
Хотя режим доступа является режимом по умолчанию, но в ряде случаев устройство, присоединённое к порту коммутатора, может перевести его в магистральный режим. Поэтому рекомендуется все немагистральные порты переводить в режим доступа командой switchport mode access.
Для статического помещения текущего интерфейса во VLAN используются команды
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan №number
где №number – число – номер VLAN.
Команда interface range определяет диапазон интерфейсов для последующих конфигураций. Например, порты с первого по шестой могут быть помещены во VLAN 10 командами
Switch(config)#interface range fa0/1 – 6
Switch(config-if-range)#switchport access vlan 10
После настройки VLAN проверьте настройку командами show runningconfig,
show vlan и show vlan brief.
При настройке VLAN помните, что по умолчанию все порты находятся
во VLAN 1.
Для создания или конфигурирования магистрали VLAN вы должны настроить порт как магистральный
Switch(config-if)#switchport mode trunk
По умолчанию последняя команда определяет порт как магистральный для всех VLAN в сети. Однако существуют ситуации, когда магистраль не должна поддерживать все VLAN. Типичной является ситуация с подавлением широковещания. Широковещание посылается на каждый порт во VLAN. Магистральная связь выступает как член VLAN и должна
пропускать всё широковещание. Если на другом конце магистрали нет портов нужной VLAN, то полоса пропускания и процессорное время устройств тратится попусту.
Если VLAN не используется на другом конце магистрали, нет нужды разрешать эту VLAN на этой магистрали. По умолчанию магистральные порты принимают и передают трафик со всех VLAN в сети. Для сокращения магистрального трафика используйте команду
Switch(config-if)#switchport trunk allowed vlan vlan-list
Например, команда
Switch(config-if)#switchport trunk allowed vlan 3
Switch(config-if)#switchport trunk allowed vlan 6-10
разрешает на магистрали VLAN 3 и затем VLAN с 6 по 10. О том, какие
VLAN разрешены на магистрали можно посмотреть командой show runningconfig.Для удаления большого числа VLANs из магистрали проще вначале удалить все VLAN, а затем выборочно разрешать. Простейший способ перевести связь в режим доступа это задать на интерфейсах с её двух сторон по команде
SwitchA(config-if)#switchport mode access
Простейший способ перевести связь в режим доступа это задать на интерфейсах с её двух сторон по команде
SwitchA(config-if)#switchport mode trunk
Практическая часть
1. Соберите топологию изображенную на рисунке 5. Коммутаторы соедините двумя GigabitEthernet (gi1/1 и gi1/2) соединениями. Компьютеры подсоедините к интерфейсам согласно таблице 1. Назначьте компьютерам адреса, согласно таблице 1. Все компьютеры входят в одну подсеть 172.16.0.0
255.255.0.0. Маршруты по умолчанию на компьютерах не устанавливайте.
Пропингуйте сеть.
Организуем в нашей сети два VLAN. Компьютеры 20_1 и 20_2 поместим во VLAN с номером 20, а компьютеры 30_1 и 30_2 поместим во VLAN с номером 30.
Switch1(conf)#interface fa0/2
Switch1(conf-if)#switchport access vlan 20
Switch1 (conf-if)#interface fa0/3
Switch1(conf-if)#switchport access vlan 30
Switch2 (conf)#interface fa0/2
Switch2(conf-if)#switchport access vlan 20
Switch2 (conf-if)#interface fa0/3
Switch2(conf-if)#switchport access vlan 30

Рисунок 5.
Таблица 1.
Компьютер Switch1 Switch2 Адрес
20_1 Fa0/2 172.16.20.1/16
30_1 Fa0/3 172.16.20.2/16
20_2 Fa0/2 172.16.30.1/16
30_2 Fa0/3 172.16.30.2/16
Gi1/1 Gi1/1 На обеих коммутаторах проверьте результаты создания VLAN, например Switch1# sh vl name 20

И

Так как нет обмена информации о VLAN между коммутаторами, то компьютеры будут пинговать только самих себя.
Организуем магистрали на коммутаторах. Для этого используем
GigabitEthernet порт
Switch1(conf)#interface gi1/1
Switch1 (conf-if)#switchport trunk allowed vlan add 20
Switch1 (conf-if)#switchport trunk allowed vlan add 30
Switch1 (conf-if)#no shutdown
Switch2 (conf)#interface gi1/1
Switch2 (conf-if)#switchport trunk allowed vlan add 20
Switch2 (conf-if)#switchport trunk allowed vlan add 30
Switch2 (conf-if)#no shutТеперь компьютеры в переделах одной VLAN должны пинговаться, а
компьютеры, находящиеся в различных VLAN не должны пинговаться (см.таблицу 2).
Таблица 2.
Ping из/в 20_1 30_1 20_2 30_2
20_1 Да Нет Да Нет
30_1 Нет Да Нет Да
20_2 Да Нет Да Нет
30_2 Нет Да Нет Да
Сохраните конфигурации коммутаторов.
2. Сохраним топологию предыдущего задания в новом файле. В этой топологии маршрутизатор соединён двумя связями с интерфейсами fa0/1 коммутаторов (рисунок 6). Снова проверьте, что компьютеры в переделах одной VLAN пингуются, а компьютеры, находящиеся в различных VLAN не пингуются.

Рисунок 6.
Поставим задачу объединения виртуальных сетей с помощью маршрутизатора. Для этого следует разбить нашу сеть 172.16.0.0/16 на две подсети 172.16.20.0/24 и 172.16.30.1/24. Для этого просто поменяем маски у компьютеров на 255.255.255.0.
Теперь компьютеры пингуются в переделах одной VLAN и в пределах одной IP подсети, а это значит только сами на себя.
Введём на коммутаторах интерфейсы, подсоединённые к маршрутизатору в виртуальные сети
Switch1(conf)#interface fa0/1
Switch1(conf-if)#switchport access vlan 20
Switch2(conf)#interface fa0/1
Switch2(conf-if)#switchport access vlan 30
Настроим IP адреса на маршрутизатореRouter(conf)#interface fa0/0
Router(conf-if)#ip address 172.16.20.254 255.255.255.0
Router(conf-if)#no shutdown
Router(conf-if)#interface fa1/0
Router(conf-if)#ip address 172.16.30.254 255.255.255.0
Router(conf-if)#no shutdown
Теперь маршрутизатор маршрутизитует наши две сети 172.16.20.0/24 и 172.16.30.1/24. Добавим на наших компьютерах маршрутизацию по умолчанию на интерфейсы маршрутизатора.
HostGataway20_1 172.16.20.254
20_2 172.16.20.254
30_1 172.16.30.254
30_2 172.16.30.254
Теперь изо всех устройств нашей сети мы можем пинговать все наши IP адреса.
3. Покажем, как с использованием транзитных линий, мы можем сэкономить порты.
Изменим топологию, перебросив магистраль gi1/2 от коммутаторов к интерфейсу fa0/0 маршрутизатора (рисунок 7). Загрузим топологию в симулятор. Загрузим по очерёдно в каждое устройство, кроме маршрутизатора, сохранённые конфигурации. Заметим, что в конфигурации коммутатора Switch2 установка магистрали на gi1/2 не нужна, хотя она и не
мешает.

Рисунок 7.
На маршрутизаторе разобъём интерфейс fa0/0 на два подинтерфейса fa0/0.20 и fa0/0.30. Определим на них инсапсуляцию dot1q и поместим их в виртуальные сети 20 и 30, соответственно.
Router(conf)#interface FastEthernet0/0.20
Router(conf-subif)#encapsulation dot1q 20
Router(conf-subif)#ip address 172.16.20.254 255.255.255.0
Router(conf-subif)#interface FastEthernet0/0.30
Router(conf-subif)#encapsulation dot1q 30
Router(conf-subif)#ip address 172.16.30.254 255.255.255.0
Посмотрим таблицу маршрутов
Router#show ip route
Проверьте, что из каждого устройства вы можете пинговать все адреса в сети.
Выполните на Router команду расширенного пинга от адреса 172.16.20.1 компьютера 20_1 из VLAN 20, подключённого к коммутатору Switch1 к адресу 172.16.30.2 компьютера 30_2 из VLAN 30, подключённого к коммутатору Switch2

Контрольные вопросы:
1. Почему предпочитают строить локальные сети с помощью коммутаторов, а не концентраторов?
2. Как коммутатор узнаёт МАС адреса подключенных устройств?
3. Где и как в коммутаторе хранятся адреса подключенных устройств?
4. Что такое виртуальное соединение и как долго оно существует?
5. Сколь большую локальную сеть можно создать с помощью коммутаторов?
6. Что является главным препятствием для создания больших локальных сетей с помощью одних только коммутаторов?
7. Что такое домен широковещания?
8. Как уменьшить домен широковещания?
9. Что такое VLAN?
10.Какие проблемы локальных сетей решает VLAN?
11.В каких режимах работают порты коммутатора?
12.Какой VLAN принадлежит магистральный порт?
13.Как распространить одну VLAN на несколько коммутаторов?
14.Можно ли организовать несколько VLAN на нескольких коммутаторах без использования магистралей?
Задание для получения повышенного бала
Повторить все пункты практической части для IP сети предприятия, согласно вариантам. Практическая часть проделана для сети 172.16.0.0/16.
Создать те же скриншоты, что и при выполнении практической части.

Приложенные файлы

Добавить комментарий