Самостоятельная работа по теме «Циклические конструкции»

МУНИЦИПАЛЬНОЕ АВТОНОМНОЕ ОБЩЕОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ «СРЕДНЯЯ ОБЩЕОБРАЗОВАТЕЛЬНАЯ ШКОЛА № 112 Г. ЧЕЛЯБИНСКА»


Выполнила учитель информатики и ИКТ
первой категории Юсупова Евгения Викторовна
г.Челябинск, 2014
Самостоятельная работа по теме «Циклические конструкции»
Вариант 1
1. Чему будет равно значение переменной n после выполнения псевдокода:
n:=0;
нц пока n<5
n:=n+3;
кц
2. Вывести квадраты натуральных чисел от 1 до 10.
Пример:
1 4 9 16 25 36 49 64 81 100

3. Что будет выводиться на экран во время выполнения псевдокода:
n:=1;
нц пока n<=10
x:=n+n;
Вывод n,x
n:=n+1;
кц
Какое условие пропущено в данном алгоритме, если в результате его работы на экран выведено значение у = - 8
а – b < b - a
a – b < b + 6
a - 12 < b + 8
a – b < b – 8
нет верного ответа












5. Даны N вещественных чисел. Найти среднее арифметическое чисел.

Самостоятельная работа по теме «Циклические конструкции»
Вариант 2
1. Чему будет равно значение переменной n после выполнения псевдокода:
n:=0;
нц пока n<5
n:=n+1;
кц
2. Вывести кубы натуральных чисел от 1 до 8.
Пример:
1 8 27 64 125 216 343 512

3. Что будет выводиться на экран во время выполнения псевдокода:
n:=1;
нц пока n<8
x:=n*n+2;
вывод n, x
n:=n+1;
кц
Какое условие пропущено в данном алгоритме, если в результате его работы на экран выведено значение Z = - 8
X < Y
X – Y < Y – X
X – Y < Y + 8
X + 14 < Y + 10
нет верного ответа















5. Даны N целых чисел. Найти среднее арифметическое чисел.

y

y = a - b



b = b + 4

а = 16

b = - 8

а = - 12

да

нет

Z

Z = X - Y



Y = Y + 4

X = 18

Y = - 10

X = - 14

да

нет



HYPER15Основной шрифт абзаца

Приложенные файлы

  • doc CRchikl
    Размер файла: 39 kB Загрузок: 1